Startseite

Outlook | Excel | Word | PowerPoint | Adobe Acrobat DC | Blog

XING | Facebook |


Pia Bork
Training, Support, Coaching für Office und Filesite


 

Impressum und Datenschutz

Creative Commons License  

Tipps und Tricks rund um Excel

A B C D E F G H I/J K
L M N O P/Q R S T U-W X-Z

 

Addieren von Uhrzeiten

  1. Einfache Addition
  2. Schichtdienst
  3. Minuszeiten

Einfache Addition

Zeiten lassen sich so einfach addieren und subtrahieren wie Zahlenwerte.

In dieser Tabelle wird in Spalte die Anfangszeit und in Spalte B die Endzeit erfasst. In Spalte C soll die Stundenzahl errechnet werden.

Die Formel lautet

=B2-A2

 

Aber die Summe in C7 kann nicht stimmen!

Sie wurde ganz normal mit =SUMME(C2:C6) errechnet und liefert dennoch ein falsches Ergebnis.

 

Das liegt am Zahlenformat. Das normale Zahlenformat für Uhrzeiten ist auf 24 Stunden fixiert und beginnt nach 24 Stunden wieder neu mit 1. Sie brauchen ein Format, das über 24 Stunden hinaus zählen kann:

  • Markieren Sie C7 und wählen Sie "Start / Zahl"
  • Klicken Sie auf den Auswahlpfeil neben "Benutzerdefiniert"
  • Wählen Sie "Mehr"

 

  • Tippen Sie unter "Typ" ein:
    [hh]:mm
  • Bestätigen Sie alles mit OK

Das bedeutet:

Jetzt muss das Ergebnis in C7 lauten 39:00.

Schichtdienst

Uhrzeiten können problemlos voneinander abgezogen werden, wenn die Anfangs- und Endezeiten am gleichen Tag sind. Die letzten Einträge in der nebenstehenden Tabelle sind aber anders:

  • Beginn ist um 21:00 Uhr eines Tages
  • das Ende ist um 7:00 des folgenden Tages

 

Excel gibt jetzt als Ergebnis eine mit Rauten gefüllte Zelle aus - es ist dabei ganz egal, wie breit Sie die Spalte machen!

Excel sieht bei allen Uhrzeiten ein unsichtbares Heute: die Schicht beginnt heute um 8:00 Uhr und endet heute um 16:30 Uhr, dazwischen liegen 8:30 Stunden. Es macht aber keinen Sinn, dass die Schichte heute um 21:00 Uhr beginnt und heute um 7:00 endet!

Der umständlichste, aber korrekte Weg wäre, die komplette Zeitangabe mit Datum und Uhrzeit zu schreiben:

Ein anderer Weg geht über eine WENN-Funktion. Zuerst wird abgefragt, ob die Endzeit kleiner ist als die Anfangszeit. Ist das der Fall, dann geht die Schicht über einen Tag hinaus. In diesem Fall wird zur Endzeit eine eins addiert, damit wandert die Uhrzeit quasi über den Tag hinaus.

Die Formel sieht so aus:

=WENN(C2<B2;C2+1-B2;C2-B2)

Noch eine Lösung funktioniert mit der Funktion REST. Die Lösung sieht so aus:

=REST(C2-B2;1)

 

Minuszeiten

Bei einer Gegenübestellung von Soll- und Ist-Zeiten ergibt sich ein Problem: Wer weniger arbeitet als er soll, erzeugt Minusstunden und die werden als ##### angezeigt.

Das hat nichts mit zu geringer Spaltenbreite zu tun. Excel kann diese Wert schlicht nicht darstellen.

 

 

Abhilfe schaffen Sie, wenn Sie die Differenz nicht als Uhrzeit in der Schreibweise hh:mm anzeigen, sondern als Dezimalschreibweise.

Die Formel lautet:

=(D2-E2)*24

Formatieren Sie die Ergebnisse als Standard oder Zahl. Die Differenz werden jetzt in den Schreibweisen 0,00 oder 2,50 angezeigt und die Minuszeit von -0,50 oder -1,00 ist kein Problem mehr.

 

Sie werden oft auch lesen, dass Sie sich einfach den sogenannten 1904-Datumswert einschalten sollten. Davon rate ich dringend ab, Sie handeln sich mehr Probleme damit ein, als Sie lösen.

Hinweis: Falls Sie in einer Zellen, die eigentlich Null ergeben sollte eine sonderbare Exponentialdarstellung erhalten wie z. B. -1,3323E-15, dann weisen Sie statt dem Zahlenformat "Standard" das Format "Zahl" zu.

It's Quiztime

Wenn Sie beide Artikel gelesen haben, dann versuchen Sie sich doch an diesem Quiz: Quiz zu Rechnen mit Uhrzeiten.

16.09.2012

 

Dezimale Schreibweise von Uhrzeiten siehe hier

 

 

 

Download

Übungstabelle